GR Freezes

Discussion in 'Ricoh' started by Gregs, Feb 15, 2014.

  1. Gregs

    Gregs New Member

    Oct 12, 2013
    Greeting to all. I just received a new GR and experienced a total camera freeze during ordinary shooting - had to pull the battery to get it to "unlock" itself and function. Wondered if anyone has experienced this. I assume this is a software glitch of some kind and not mechanical, but am considering returning the camera. My previous GR worked flawlessly without any such issues. I did upgrade this one to current firmware, so perhaps its related to that. I also noticed that the new one had different feel to the ruberized externals and metal casing - former more grippy/thicker, case with more texture, battery door springy etc - seems like they may have changed supplier for parts, perhaps due to increased demand. Wonder if anyone knows where they're manufactured, how good the quality control is etc. The freezing was a surprise, and am not sure if this occasionally happens, or is a marker for possible mechanical/build issues which would warrant returning. The camera worked fine for the first few days. I bought from amazon, so the return is not an issue. Thanks.
  2. mcentral

    mcentral Regular

    Oct 27, 2013
    cambridge, massachusetts
    Don't know the answer to your questions about possible changes with the manufacturing, but I have read reports of occasional freeze ups. It doesn't seem to be a chronic issue from what I can tell. My own experience, after about six months of use with an early-ish copy, is two freeze-up episodes requiring the removal of the battery. These came in the first weeks and initially made me think that something was wrong. I decided to just ride it out and it hasn't happened since. So my sense is that you can't make any conclusions about changes with the manufacturing based on a couple of freezes, because the older versions also could have a random freeze or two. Can't speak about a different feel to the externals.
  3. PZilla

    PZilla New Member

    Apr 5, 2014
    Happened to me the other day ( 2nd day of ownership )
    Had to pull the battery out.
    Think I pressed the preview button a bit to soon after taking a burst of shots.

    Also noticed some strange behaviour when changing focus modes, and having to turn off / on to make them apply.

    Got my GR used, but still has plenty of warranty left on it. - firmware is up to date.